Initial Router Configuration

How to initially configure a router from scratch (NOT using the autoinstall feature that prompts you through all the commands). This configuration is complete for LAB_A and needs to be modified where appropriate for the particular router you are working on (different IPs for LAB_B, C, D, E; some of the routers don't use all the interfaces, etc.)

Router> enable

Router# config t

Router(config)# hostname LAB_A

LAB_A(config)# enable secret class

LAB_A(config)# enable password class

LAB_A(config)# ip routing

LAB_A(config)# exit

LAB_A# copy run start

LAB_A# exit

LAB_A> enable

Password: class

LAB_A# config t

LAB_A(config)# int e0

LAB_A(config-if)# ip address 192.5.5.1 255.255.255.0

LAB_A(config-if)# no shutdown

LAB_A(config-if)# exit

LAB_A(config)# exit

LAB_A# copy run start

LAB_A# config t

LAB_A(config)# int e1

LAB_A(config-if)# ip address 205.7.5.1 255.255.255.0

LAB_A(config-if)# no shutdown

LAB_A(config-if)# exit

LAB_A(config)# exit

LAB_A# copy run start

LAB_A# config t

LAB_A(config)# int s0

LAB_A(config-if)# ip address 201.100.11.1 255.255.255.0

LAB_A(config-if)# no shutdown

LAB_A(config-if)# clock rate 56000

LAB_A(config-if)# exit

LAB_A(config)# exit

LAB_A# copy run start

LAB_A# config t

LAB_A(config)# int s1

LAB_A(config-if)# no shutdown

LAB_A(config-if)# exit

LAB_A(config)# exit

LAB_A# copy run start

Initial Router Configuration - pg. 2

LAB_A# config t

LAB_A(config)# ip routing

LAB_A(config)# exit

LAB_A# copy run start

LAB_A# config t

LAB_A(config)# router rip

LAB_A(config-router)# network 192.5.5.0

LAB_A(config-router)# network 205.7.5.0

LAB_A(config-router)# network 201.100.11.0

LAB_A(config-router)# exit

LAB_A(config)# exit

LAB_A# copy run start

LAB_A# config t

LAB_A(config)# ip host LAB_A 192.5.5.1 205.7.5.1 201.100.11.1

LAB_A(config)# ip host LAB_B 219.17.100.1 199.6.13.1 201.100.11.2

LAB_A(config)# ip host LAB_C 223.8.151.1 204.204.7.1 199.6.13.2

LAB_A(config)# ip host LAB_D 210.93.105.1 204.204.7.2

LAB_A(config)# ip host LAB_E 210.93.105.2

LAB_A(config)# exit

LAB_A# copy run start

LAB_A# config t

LAB_A(config)# line vty 0 4

LAB_A(config-line)# password george

LAB_A(config-line)# login

LAB_A(config-line)# exit

LAB_A(config)# exit

LAB_A# copy run start